Author Topic: Explorist 610 acting up...  (Read 2911 times)

0 Members and 1 Guest are viewing this topic.

Geofern

  • Guest
Explorist 610 acting up...
« on: July 08, 2013, 18:42:12 »
 >:( >:(Good evening...
 
I have a Explorist 610 loaded with the latest software.. Serial#0149000093466 While Geocaching, MOST of the time, the compass will freeze for several minutes, the distance to end will update very slow as I get close to destination and walking SLOW. It would show 20 meters then all the sudden 3 meters or so (I know there is a margin of error for accuracy) but it could maintained a 15 meters or so distance from a cache when I know I am about 50 meters away from the cache. The compass freezes on a bearing for minutes when I know it should be moving; this happens specially if there are trees around.. Any ideas???
 

royfran

  • Full Time Cacher
  • ***
  • Posts: 164
Re: Explorist 610 acting up...
« Reply #1 on: July 08, 2013, 20:00:23 »
Make sure you didn't (by accident or voluntarily) set it to "battery save" mode.  I did that once and it made it behave more or less like what you describe.  As for the compass, it seems to get disoriented if you move very slowly and I have learned (more or less) to accept it as a flaw and live with it.

F0restGrump

  • Guest
Re: Explorist 610 acting up...
« Reply #2 on: July 10, 2013, 10:12:21 »
It could be there is a problem with the latest version of firmware you loaded. I have found that my 310 acts strangely after some firmware updates. As a matter of fact, the latest (1.68?) seems to be really slow. I am going to have to post something on the Magellen site about this.

The electronic compass should not be affected by movement, it should just work. On my 310, I know not to count on my compass, but it is derived from the GPS signal so movement is required in it's case.

Cheers, FG

FoxEcho

  • Guest
Re: Explorist 610 acting up...
« Reply #3 on: December 20, 2013, 05:56:00 »
The 610 is now on sale at $250 (50% off) at Cdn Tire