Author Topic: New Oregon x50 Firmware 4.50 / 62 series ver. 3.00  (Read 2506 times)

0 Members and 1 Guest are viewing this topic.

imercator

  • Guest
New Oregon x50 Firmware 4.50 / 62 series ver. 3.00
« on: May 28, 2011, 21:00:12 »
Well Garmin finally officially released a, hopefully, stable version of it's Oregon x50 series firmware. Updates are available on Garmin.com when you log into "myGarmin".

They have been tinkering with at least 5 beta versions since 4.20, which was the last stable release.

I upgraded this morning without a hiccup but it's too early to tell what, if any, bugs have been introduced. I only found two caches with it and still can't better than 3m accuracy even with the improved WAAS functionality. There are still a handful of useful options that haven't been added for my liking, proximity circles and the ability to add comments to a cache on the fly for example.  Looking at the list of changes below it appears more like their objective was to repair 4.20 rather than increase functionality.

Feel brave? :o

Cheers,
imercator

---------------------------------------------------------------------------------------------------------------

Changes made from version 4.20 to 4.50:

Updated magnetic Earth field data
Improved GPS performance
Improved support for BirdsEye™ Satellite Imagery (each provider's imagery can be configured independently)
Increased the maximum number of supported JNX files to 250 from 200
Fixed issues with WAAS/EGNOS
Fixed issue with track navigation sometimes not adding waypoints to the Active Route list
Fixed issue with MPC map labels disappearing
Fixed shutdown on the map page when you have a geocache dashboard active and return after pressing the geocache name
Fixed issue with moon not showing on sun and moon page
Fixed issue with photo viewer not displaying correctly
Fixed issue with progress bar displaying properly on power up
Fixed issue with waypoint distances showing significantly off in the waypoint manager
Fixed issue with 3D view
Fixed issue with track navigation not adding waypoints to the Active Route list when they are exactly equal to a track point
Fixed shutdown when more than the maximum number of JNX files were present
Fixed 'Search Near' functionality on Hunt & Fish and Sun & Moon pages
Fixed shutdown related to topographical maps and land cover text size
Fixed shutdown associated with certain custom POI files
Fixed Glide Ratio to Destination field
Fixed problem with profiles and the fields on the map page
Fixed an issue with magnetic north reference and waypoint headings
Fixed shutdown on the map screen when a waypoint was being moved to the same location as a geocache or other POIs
Fixed an issue with archived tracks not displaying properly
Fixed an issue with having too many custom symbols on the device
Fixed an issue with renaming a waypoint immediately after creating it
Modified the 'Arriving at Destination' message banner so that it no longer appears when navigating to a geocache
« Last Edit: May 28, 2011, 22:48:25 by kirok »

CocaColaCacher

  • Sr. Cacher
  • ****
  • Posts: 326
Re: New Oregon x50 Firmware 4.50
« Reply #1 on: May 28, 2011, 21:26:43 »
Finally, that annoying "arriving at" message gone!  That alone is worth the download.

kirok

  • Administrator
  • Big Time Cacher
  • *****
  • Posts: 691
  • "To boldly find what no cacher has logged before!"
    • Binthair Challenge
Re: New Oregon x50 Firmware 4.50
« Reply #2 on: May 28, 2011, 22:47:49 »
The identical update is now available for the 62 series as well (except the version # is 3.00)

dcmg

  • Guest
And the Oregon x00 FW is updated to 4.20, although not as many feature/updates apply to the x00s:

Changes made from version 4.10 to 4.20:
 Updated magnetic Earth data
Improved GPS performance
Improved support for BirdsEye™ Satellite Imagery (each provider's imagery can be configured independently)
Increased the maximum number of supported JNX files to 250 from 200
Fixed issues with WAAS/EGNOS
Fixed issue with track navigation sometimes not adding waypoints to the Active Route list
Fixed issue with MPC map labels disappearing
Fixed shutdown on the map page when you have a geocache dashboard active and return after pressing the geocache name
Fixed issue with photo viewer not displaying correctly
Fixed issue with 3D view
Fixed issue with track navigation not adding waypoints to the Active Route list when they are exactly equal to a track point
Fixed shutdown when the device had more than the maximum number of JNX files on it
Fixed shutdown related to topographical maps and land cover text size
Fixed shutdown associated with certain custom POI files
Fixed Glide Ratio to Destination field
Fixed an issue related to adding a geocache as a point in a route
Fixed an issue with magnetic north reference and waypoint headings
Modified the 'Arriving at Destination' message banner so that it no longer appears when navigating to a geocache

Who's going to try it first. :-)

--DCMG

graciious

  • Guest
Re: New Oregon x50 Firmware 4.50 / 62 series ver. 3.00
« Reply #4 on: May 30, 2011, 06:50:54 »
I am still running with the original 62s software.  It has been working fine for me, I am not sure I want to update.  It seems like everything I update dies shortly there after.

missbug

  • Guest
Re: New Oregon x50 Firmware 4.50 / 62 series ver. 3.00
« Reply #5 on: May 30, 2011, 08:42:17 »
exciting! i shall be brave and try it soon.. i like that the 'arriving' banner is gone too!!

kirok

  • Administrator
  • Big Time Cacher
  • *****
  • Posts: 691
  • "To boldly find what no cacher has logged before!"
    • Binthair Challenge
Re: New Oregon x50 Firmware 4.50 / 62 series ver. 3.00
« Reply #6 on: May 30, 2011, 10:52:31 »
Confirmed that the "arriving" message is gone from, but I really wish it was an option you could just turn on and off. It still does it for waypoints and pois.

Seems stable so far (on my 62) but I do find it a bit slower when loading caches from the memory card. I can live with that if it means fewer crashes.

missbug

  • Guest
Re: New Oregon x50 Firmware 4.50 / 62 series ver. 3.00
« Reply #7 on: June 06, 2011, 09:41:08 »
4.50 seemed to install and load correctly on my oregon 550.. haven't been out yet to try it though!

portera

  • Big Time Cacher
  • *****
  • Posts: 581
  • Yes, I probably should be working...
Re: New Oregon x50 Firmware 4.50 / 62 series ver. 3.00
« Reply #8 on: June 06, 2011, 09:53:54 »
The one thing I noticed right away with the last update (4.49 - yah, I know I'm one behind) when I went out to hide Public Art - Redux last week was that when you zoom in to a certain level, the green background in Canada Topo4 gets lighter, so the rest of the map detail is easier to see in bright light. I suppose that it did this before, but I don't recall it. Simple change, but very helpful.