Author Topic: BETA GSAK8  (Read 9664 times)

0 Members and 1 Guest are viewing this topic.

missbug

  • Guest
Re: BETA GSAK8
« Reply #30 on: November 10, 2011, 11:39:16 »
i wonder why mine isn't working  ???

portera

  • Big Time Cacher
  • *****
  • Posts: 581
  • Yes, I probably should be working...
Re: BETA GSAK8
« Reply #31 on: November 10, 2011, 14:35:38 »
i wonder why mine isn't working  ???

Are you using it at work or at home?

missbug

  • Guest
Re: BETA GSAK8
« Reply #32 on: November 10, 2011, 14:42:13 »
work!

portera

  • Big Time Cacher
  • *****
  • Posts: 581
  • Yes, I probably should be working...
Re: BETA GSAK8
« Reply #33 on: November 10, 2011, 15:07:27 »
work!

It is possible (and actually quite likely) that your work LAN has the port blocked that is used between GSAK and the Groundspeak API. The error message that you posted would indicate that to me.

cron

  • Guest
Re: BETA GSAK8
« Reply #34 on: November 10, 2011, 15:19:48 »
It's using port 80 and 443 (HTTP and HTTPS) only. I just ran a packet sniffer while connecting to the API. If you can browse www.geocaching.com, then you can access the API.

missbug

  • Guest
Re: BETA GSAK8
« Reply #35 on: November 10, 2011, 15:58:35 »
thanks. then what is the problem?

HoundGPS

  • Guest
Re: BETA GSAK8
« Reply #36 on: November 24, 2011, 09:37:58 »
thanks. then what is the problem?

You may have probably done so already, but just in case this may be the problem...
Before you can use the API fonctionality, you have to allow GSAK to use your geocaching.com account in your stead by giving it a authentication "Token".
To do so, do the following :
- Access "Geocaching.com access" -> "Get another access token"
- In the small browser-like window that appears, enter your geocaching.com username and password.
- Then geocaching.com will ask you if you wish to allow GSAK to access your geocaching.com information on your behalf. Hit "Allow Access".

After that, you will be able to use all of the Groundspeak API functionalities added to GSAK.


As for me, yes I paid for the upgrade as I like the software and I love the new functionalities added. Better management of stagnant caches in database that have been archived on geocaching.com is the major seller for me. Easier importing of the pocket queries is another.

I paid 15$ for the upgrade. Well worth it IMHO.
« Last Edit: November 24, 2011, 09:46:58 by HoundGPS »

missbug

  • Guest
Re: BETA GSAK8
« Reply #37 on: November 24, 2011, 10:42:42 »
thanks, HoundGPS! that worked fine, but then i still got the same error. i am thinking it's a proxy issue. and that does not make me happy!

HoundGPS

  • Guest
Re: BETA GSAK8
« Reply #38 on: November 24, 2011, 10:53:03 »
Ah! Quite possible :)

Do you know for a fact that your workplace uses a proxy server? This will be cause for issue according to the following :

Quote
If your internet access is via a proxy server (common in work place environments), then enter the details here. The default is to use IE settings, which means GSAK will use the same proxy server (if any configured) as Internet Explorer.

Note: If you are using an authenticating proxy server you *must* uncheck the "Use IE settings" and enter your proxy server details, otherwise your proxy connections will not work (GSAK needs to access the the api via the proxy server and IE settings are not supported for this access method when using the Groundspeak api)

Source : http://gsak.net/help/hs7842.htm

missbug

  • Guest
Re: BETA GSAK8
« Reply #39 on: November 24, 2011, 11:35:37 »
we are getting there!! my error list is shorter, after attempting to uncheck the IE proxy box thing and add my username, passwork, server and port.. not sure if i put in the correct ones but i didn't pass go...

here is my new error. the old one is a page back in this thread.

edit to say i realize i mistyped the server name and corrected that. it searches but then still says no go.
« Last Edit: November 24, 2011, 11:49:52 by missbug »

CocaColaCacher

  • Sr. Cacher
  • ****
  • Posts: 326
Re: BETA GSAK8
« Reply #40 on: November 24, 2011, 13:11:36 »
What are your proxy settings in Internet Explorer?

In IE  Tools -> Internet Options -> Connections -> LAN settings

Make sure you are using those in your GSAK setup.

Don't use what I have in the pic, yours will depend on how your network is setup. 

« Last Edit: November 24, 2011, 13:13:25 by CocaColaCacher »

HoundGPS

  • Guest
Re: BETA GSAK8
« Reply #41 on: November 24, 2011, 13:29:18 »
Hmmm... according to the error message, it was unable to establish a connection to the proxy server.
Since the error message is not specific enough as to the reason of its failure to connect, it could very well be either of the following:

- Proxy Server host name is not reachable (wrong server name)
- Wrong port
- Bad username
- Bad password
- Any combination of the above.

If you know your LAN admin personnally, you may be able to score more information on the proper use of the proxy server.
On large networks, proxy servers are normally assigned to the users profile via domain controller logon scripts and could also use an automatic proxy configuration script.
This is all technical mombo-jimbo of course, but in short, it may very well be that not many people in your workplace actually knows what the true credentials are to initiate a connection to the proxy server.

One usually-safe assumption is to use your normal network login and password, but in some setups, user profiles may be using generic proxy server credentials.

Best thing to do is to find someone who knows them :)
« Last Edit: November 24, 2011, 13:31:23 by HoundGPS »

HoundGPS

  • Guest
Re: BETA GSAK8
« Reply #42 on: November 24, 2011, 13:44:56 »
Another possibility I have just thought of, is the fact that some network setups only proxies unsecured connections to the web (those going through port 80) and leaves the SSL port (443) open on the firewall.

To test this, you can put your GSAK back on to "Use IE Settings" and go into your Internet Explorer LAN Settings and deactivate the use of the proxy. This will force GSAK to use a direct connection through 443 instead of trying to go via the proxy.

missbug

  • Guest
Re: BETA GSAK8
« Reply #43 on: November 24, 2011, 14:03:47 »
thanks so much for trying to help!! i think you're right about asking IT to tell me what the settings are (i know a couple of the guys). when i re-checked the 'use IE settings' box in GSAK, i went into IE LAN settings but that was already deactivated.. (proxy unchecked). i monkeyed around a bit but still doesnt work. sigh!! maybe one day this will get sorted out. tres disappointing.

thanks again!  :D

HoundGPS

  • Guest
Re: BETA GSAK8
« Reply #44 on: November 24, 2011, 14:15:18 »
Hehe np :)

From the initial error message you got, we could already tell that it was not going through the proxy. It managed to establish a connection to groundspeak on the SSL port (443), but the connection was severed by the firewall, probably because it did not recognize the headers as being from an authorized application for the SSL connection. In short, the firewall has access to decrypt the SSL contents of the connection and sees that it was not made by a browser and therefore severs it.

Your IT guys will be able to tell you that ;)

If it is indeed the case, you are pretty much SOL for using this at work :(
« Last Edit: November 24, 2011, 14:17:45 by HoundGPS »